Although 3DS has been updated to 6.3.0-12U/J/E, Supercard DStwo can work on 6.3.0-12 smoothly.

According to our test, our Supercard DStwo work directly on 3DS 6.3.0-12U.

3DS 6.3.0-12

No related posts.